const regex = /\[([0-9]{4}\.[0-9]{2}\.[0-9]{2} [0-9]{2}:[0-9]{2}:[0-9]{2})\] \[([a-zA-Z]+)\] \[(.+)\] \[(.+)\] (.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[([0-9]{4}\\.[0-9]{2}\\.[0-9]{2} [0-9]{2}:[0-9]{2}:[0-9]{2})\\] \\[([a-zA-Z]+)\\] \\[(.+)\\] \\[(.+)\\] (.*)', 'gm')
const str = `[2019.01.10 22:45:37] [INFO] [main] [Config] Starting to load configuration!
[2019.01.10 22:45:38] [WARN] [main] [Config] Value for key: shard_num was not provided! Using default value: "-1"
[2019.01.10 22:45:39] [WARN] [main] [Config] Value for key: default_prefix was not provided! Using default value: ";"
[2019.01.10 22:45:39] [WARN] [main] [Config] Value for key: haste.server was not provided! Using default value: "https://hastebin.com/documents"
[2019.01.10 22:45:39] [WARN] [main] [Config] Value for key: haste.link was not provided! Using default value: "https://hastebin.com/"
[2019.01.10 22:45:39] [INFO] [main] [Config] Finished loading configuration!
[2019.01.10 22:45:43] [INFO] [main] [ShardManager] Login Successful!
[2019.01.10 22:45:43] [INFO] [main] [Command Manager] Loaded 7 commands in 85ms.
[2019.01.10 22:45:43] [INFO] [JDA [0 / 1] MainWS-WriteThread] [WebSocketClient] Connected to WebSocket
[2019.01.10 22:45:43] [INFO] [JDA [0 / 1] MainWS-ReadThread] [JDA] Finished Loading!
[2019.01.10 22:45:43] [INFO] [JDA [0 / 1] MainWS-ReadThread] [CascadeBot] All shards successfully logged in!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}