#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\/\*[\w\'\s\r\n\*]*\*\/)|(\/\/[\w\s\']*)"
Local $sString = "/*api.runTests(true);*/" & @CRLF & _
"//asdfasdf" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"/*" & @CRLF & _
"field.activate(true);" & @CRLF & _
"*" & @CRLF & _
"*/" & @CRLF & _
"" & @CRLF & _
"/*" & @CRLF & _
"" & @CRLF & _
"*/" & @CRLF & _
"" & @CRLF & _
"/****" & @CRLF & _
" * Common multi-line comment style." & @CRLF & _
" ****/" & @CRLF & _
" " & @CRLF & _
"/****" & @CRLF & _
" * Another common multi-line comment style." & @CRLF & _
" */"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")