import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(ST)REET|(AVE)NUE|(B)OU(L)E(V)AR(D))";
final String string = "I live on 56 something STREET\n"
+ "I live on 56 something AVENUE\n"
+ "I live on 56 something BOULEVARD\n";
final String subst = "\\1\\2\\3\\4\\5\\6";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}