const regex = /(?:(ST)REET|(AVE)NUE|(B)OU(L)E(V)AR(D))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(ST)REET|(AVE)NUE|(B)OU(L)E(V)AR(D))', 'g')
const str = `I live on 56 something STREET
I live on 56 something AVENUE
I live on 56 something BOULEVARD
`;
const subst = `\1\2\3\4\5\6`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);