$re = '/^(?:.*=([^\r\n=]+)=[^=\r\n]+$|[^\r\n=]+)/m';
$str = 'I have candy=\'4\' and ice cream = \'vanilla\'
I have candy=\'4\' and ice cream = \'vanilla\' and house=\'big\'
test test =\'test test test\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);