package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(Jan|Fev|Ma[ri]|Abr|Ju[ln]|Ago|Set|Out|Nov|Dez)\/(Se[gx]|Ter|Qu[ai]|Sab|Dom)$`)
var str = `Jan/Seg
Fev/Ter
Mar/Qua
Abr/Qui
Mai/Sex
Jun/Sab
Jul/Dom
Ago/Seg
Set/Ter
Out/Qua
Nov/Qui
Dez/Sex
dez/sab
Abc/Def`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}