use strict;
my $str = 'Jan/Seg
Fev/Ter
Mar/Qua
Abr/Qui
Mai/Sex
Jun/Sab
Jul/Dom
Ago/Seg
Set/Ter
Out/Qua
Nov/Qui
Dez/Sex
dez/sab
Abc/Def';
my $regex = qr/^(Jan|Fev|Ma[ri]|Abr|Ju[ln]|Ago|Set|Out|Nov|Dez)\/(Se[gx]|Ter|Qu[ai]|Sab|Dom)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}