re = /\[\[title]](.*?)^$/m
str = '[[title]]
a = "1"
b = "1"
c = "1"
d = "1"
e = [
"1",
"1",
]
[[title]]
a = "2"
b = "2"
c = "2"
d = "2"
e = [
"2",
]
[[title]]
a = "a3"
b = "3"
c = "3"
[[title]]
a = "a4"
b = "4"
c = "4"
e = [
"4",
]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end