package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]{1,3}((\,[0-9]{3})*)\.[0-9]{2}[kmb]?$`)
var str = `0.00
123.12k
123,123,123.12m
123,123,123,123.00b`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}