$re = '/^[0-9]{1,3}((\,[0-9]{3})*)\.[0-9]{2}[kmb]?$/m';
$str = '0.00
123.12k
123,123,123.12m
123,123,123,123.00b';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);