$re = '/((?<=[a-z0-9])[A-Z]|(?!^)(?<!_)[A-Z](?=[a-z]))/m';
$str = 'camelCase
camelCase123
camelCASE
camel1Case
HTTPError
camelCaseD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);