package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\w+\-]){6,}`)
var str = `" 3 89 -90/ 900407-2"
" 3 9 -90/ 900407-1"
" 89 -9011/ 800408"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}