const regex = /\[([^]]+)\] => (?:Array(*SKIP)(*FAIL)|(.*)\s+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[([^]]+)\\] => (?:Array(*SKIP)(*FAIL)|(.*)\\s+)', 'g')
const str = `Array
(
[0] => 32
[1] => Array
(
[uuid] => 92bbf05c-b49e-4950-9d4a-69c226325131
[conversation_uuid] => CON-ee2287cb-ddb7-47e3-9595-0b4d36ac57e3
[status] => failed
[direction] => outbound
)
)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}