import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(25 Eur)$";
final String string = "Apple Itunes 25 Euro Guthaben Prepaid De', 'Apple iTunes 25 Euro\n"
+ "25 Eur";
final String subst = "Steam 25 Euro";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}