$re = '/^(25 Eur)$/m';
$str = 'Apple Itunes 25 Euro Guthaben Prepaid De\', \'Apple iTunes 25 Euro
25 Eur';
$subst = "Steam 25 Euro";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;