import Foundation
let pattern = #"^(25 Eur)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Apple Itunes 25 Euro Guthaben Prepaid De', 'Apple iTunes 25 Euro
25 Eur
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Steam 25 Euro"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)