using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?|ftp):\/\/[^ ]+";
string input = @"טקסט שיש בו כתובות אינטרנט https://regex101.com/ ואני רוצה לחלץ את הדומיין למשל. http://tchumim.com/topic/1463/regex-%D7%91%D7%99%D7%98%D7%95%D7%99%D7%99%D7%9D-%D7%A8%D7%92%D7%95%D7%9C%D7%A8%D7%99%D7%99%D7%9D/3 וכמובן שהזכויות שמורות לתחומים.קום שהכתובת היא http://tchumim.com";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}