package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(https?|ftp):\/\/[^ ]+`)
var str = `טקסט שיש בו כתובות אינטרנט https://regex101.com/ ואני רוצה לחלץ את הדומיין למשל. http://tchumim.com/topic/1463/regex-%D7%91%D7%99%D7%98%D7%95%D7%99%D7%99%D7%9D-%D7%A8%D7%92%D7%95%D7%9C%D7%A8%D7%99%D7%99%D7%9D/3 וכמובן שהזכויות שמורות לתחומים.קום שהכתובת היא http://tchumim.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}