import Foundation
let pattern = #"(https?|ftp):\/\/[^ ]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"טקסט שיש בו כתובות אינטרנט https://regex101.com/ ואני רוצה לחלץ את הדומיין למשל. http://tchumim.com/topic/1463/regex-%D7%91%D7%99%D7%98%D7%95%D7%99%D7%99%D7%9D-%D7%A8%D7%92%D7%95%D7%9C%D7%A8%D7%99%D7%99%D7%9D/3 וכמובן שהזכויות שמורות לתחומים.קום שהכתובת היא http://tchumim.com"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)