package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\b\d\b.*`)
var str = `Привет я был в 2часа
Сегодня в2 часа
Сегодня вчаса2
Это было в2часа
Привет он был в 2 часа
Привет я был в 22часа
Сегодня в22 часа
2 часа не было меня
22 часа не было меня
Это было в22часа
Привет он был в 22 часа
2
22
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}