#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!(([0-9])\1{7}([0-9]){1}|12345678([0-9]){1}|(123){3,9}))"
Local $sString = "000000001" & @CRLF & _
"000000009" & @CRLF & _
"333333333" & @CRLF & _
"777777775" & @CRLF & _
"999999990" & @CRLF & _
"999999999" & @CRLF & _
"123123123" & @CRLF & _
"123456780" & @CRLF & _
"123456785" & @CRLF & _
"123456789" & @CRLF & _
"123654789" & @CRLF & _
"102030405" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")