re = /(?!(([0-9])\1{7}([0-9]){1}|12345678([0-9]){1}|(123){3,9}))/m
str = '000000001
000000009
333333333
777777775
999999990
999999999
123123123
123456780
123456785
123456789
123654789
102030405
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end