# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"§§\s*((?:Satz|Abs\.|Nr\.|\d+[a-z]?|und|[\s,])+)(?<=\w)"
test_str = ("\n\n"
"Die Anzahl der §§ 12 Abs. 5, 13a, 14 Satz 1 und 8 variieren\n"
" From this string I want to get the part 12 Abs. 5, 13a, 14 Satz 1 und 8. The string could also be \n"
"Für die §§ 15a, 18 Abs. 5, 21 und 23 Satz 3 trifft dies nicht zu\n"
" Here I want to get 15a, 18 Abs. 5, 21 und 23 Satz 3")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.