$re = '/\"name\":\s+\"(?<name>[^\"]+)\",\s+\"result\":\s+(?<result>\w+)/m';
$str = '{"name": "abc def - 123", "result": true}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);