using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<TopicSet FormalName=""PARENT1"">(?:(?:\s|\S)*?)TopicType FormalName=""(.+)""(?:(?:\s|\S)*?)<\/TopicSet>";
string input = @"<TopicSet FormalName=""PARENT1"">
<Topic>
<TopicType FormalName=""Child1"" />
</Topic>
<Topic>
<TopicType FormalName=""Child2"" />
</Topic>
<Topic>
<TopicType FormalName=""Child3"" />
</Topic>
</TopicSet>
<TopicSet FormalName=""PARENT2"">
<Topic>
<TopicType FormalName=""Child1"" />
</Topic>
<Topic>
<TopicType FormalName=""Child2"" />
</Topic>
<Topic>
<TopicType FormalName=""Child3"" />
</Topic>
</TopicSet>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}