re = /<TopicSet FormalName="PARENT1">(?:(?:\s|\S)*?)TopicType FormalName="(.+)"(?:(?:\s|\S)*?)<\/TopicSet>/m
str = '<TopicSet FormalName="PARENT1">
<Topic>
<TopicType FormalName="Child1" />
</Topic>
<Topic>
<TopicType FormalName="Child2" />
</Topic>
<Topic>
<TopicType FormalName="Child3" />
</Topic>
</TopicSet>
<TopicSet FormalName="PARENT2">
<Topic>
<TopicType FormalName="Child1" />
</Topic>
<Topic>
<TopicType FormalName="Child2" />
</Topic>
<Topic>
<TopicType FormalName="Child3" />
</Topic>
</TopicSet>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end