re = /^[a-z][\w]+@[a-z]+.com$/m
str = 'rcedsRsa@gmail.com
rcedsEas1a@gmail.com
a11111111@gmail.com
asdasd123@asdas.com.br'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end