use strict;
my $str = '000102030405060708090A0B0C0D0E0F101112131415161718191A1B1C1D1E1F';
my $regex = qr/(..)(..)(..)(..)(..)(..)(..)(..)(..)(..)(..)(..)(..)(..)(..)(..)/mp;
my $subst = '\\t0x$1,0x$2,0x$3,0x$4,0x$5,0x$6,0x$7,0x$8,0x$9,0x$10,0x$11,0x$12,0x$13,0x$14,0x$15,0x$16\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";