using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"information\/([0-9]{4})\/([0-9]{1,2})\/([0-9]{1,2})\/([0-9]{1,})\/?$";
string input = @"http://single.test/information/2024/03/25/1867/
http://single.test/information/2024/03/25/1869/
http://single.test/information/2024/03/25/169/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}