import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "information\\/([0-9]{4})\\/([0-9]{1,2})\\/([0-9]{1,2})\\/([0-9]{1,})\\/?$";
final String string = "http://single.test/information/2024/03/25/1867/\n"
+ "http://single.test/information/2024/03/25/1869/\n"
+ "http://single.test/information/2024/03/25/169/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}