# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([\w-]+)-\d{4}-\d{2}-\d{2}-\d{2}-\d{2}-\d{2}.gz$/$1/gmi;t' <<< "repo-2019-12-31-14-30-11.gz"