#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)\b" & @CRLF & _
"(?:" & @CRLF & _
" Length\ +(?<Length>\d+(?:\.\d+)?|\d+-\d+\/\d+)\ +(?:in|ft|cm|m)|" & @CRLF & _
" Width\ +(?<Width>\d+(?:\.\d+)?)\ +(?:in|ft|cm|m)|" & @CRLF & _
" Weight\ +(?<Weight>\d+)\ +(?:oz|lb|g|kg)" & @CRLF & _
")" & @CRLF & _
"\b"
Local $sString = "Width 3.5 in" & @CRLF & _
"Weight 10 kg" & @CRLF & _
"Length 6-3/4 m" & @CRLF & _
"" & @CRLF & _
"Note I've set the 'x' (extended) flag to make it easier to view the regex. " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")