use strict;
my $str = '/wp-admin/LongFancy____-----Sitename___---Matches_My_Pattern.php
/wp-admin/user/test.php
/wp-admin/other/test.php
/wp-admin/network/test.php
/wp-admin/test.php';
my $regex = qr@^/wp-admin/(?:network/|user/)?[\w-]+\.php$@mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}