package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^:]*:){3}\s*(\S.*)`)
var str = `user_name_1, 10:46:36 activity_name_1 : the text to be returned`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}