$re = '/^(?:[^:]*:){3}\s*(\S.*)/m';
$str = 'user_name_1, 10:46:36 activity_name_1 : the text to be returned';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);