re = /^(?:[^:]*:){3}\s*(\S.*)/m
str = 'user_name_1, 10:46:36 activity_name_1 : the text to be returned'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end