// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)@@\s([-\+]?\d+,[-\+]?\d+)\s([-\+]?\d+,[-\+]?\d+)").unwrap();
let string = "@@ -74,-6 +73,-7 @@
<dependency> <groupId>com.jolbox</groupId>
<artifactId>bonecp-test
- commons</artifactId>
+ <classifier>${project.classifier}</classifier>
<scope>test</scope>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}