#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*?([abcde]).*\1)(?1){5}$"
Local $sString = "Should pass:" & @CRLF & _
"abcde" & @CRLF & _
"" & @CRLF & _
"Should fail:" & @CRLF & _
"Too short:" & @CRLF & _
"abcd" & @CRLF & _
"Too long" & @CRLF & _
"abcdef" & @CRLF & _
"Missing required char:" & @CRLF & _
"fghij" & @CRLF & _
"Duplicates:" & @CRLF & _
"aaaaa" & @CRLF & _
"abcbc" & @CRLF & _
"afgha" & @CRLF & _
"fgaah" & @CRLF & _
"Previously-passing cases:" & @CRLF & _
"afghi" & @CRLF & _
"fgahi" & @CRLF & _
"fghia"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")