#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(half|quarter|third|\d+)|."
Local $sString = "here is some text with stuff inside that i dont need but also some that i do, here is a word half and quarter also 99 is too old for lego" & @CRLF & _
"heres another one with numbers 132 1244 5950 303 2022 and one and a half" & @CRLF & _
"plz help me with code i am struggling"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)