using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":(?:\s*(?!SCHEDULED)[A-Z]+)+";
string input = @":CITYNAMEONE SCHEDULED
:CITY NAME TWO
:CITYNAMETHREE
: ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}