// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r"(?:H\s*=\s*{{H-Sätze)((\|\d{3})*)(}})(?:\n|)").unwrap();
  let string = "\"{{Infobox Chemikalie\\n| Strukturformel  = [[Datei:Nitric-acid.png|125px|Struktur von Salpetersäure]]\\n| Suchfunktion    = HNO3\\n| Andere Namen    = * Dioxidohydroxidostickstoff\\n* Scheidewasser\\n* Hydrogennitrat\\n| Summenformel    = HNO<sub>3</sub>\\n| CAS             = 7697-37-2\\n| EG-Nummer       = 231-714-2\\n| ECHA-ID         = 100.028.832\\n| PubChem         = 944\\n| Beschreibung    = in reiner Form farblose Flüssigkeit, durch Licht oder Wärme teilweise Zersetzung zu [[Stickoxide]]n unter Gelb- bis Rotfärbung<ref name=\\\"roempp\\\">{{RömppOnline|Name=Salpetersäure |Datum=12. November 2014 |ID=RD-19-00221 }}</ref>\\n| Molare Masse    = 63,01 g·[[mol]]<sup>−1</sup><ref name=\\\"GESTIS\\\" />\\n| Aggregat        = flüssig\\n| Dichte          = 1,51 g·cm<sup>−3</sup> (20 °C)<ref name=\\\"GESTIS\\\" />\\n| Schmelzpunkt    = −42 [[Grad Celsius|°C]]<ref name=\\\"GESTIS\\\" />\\n| Siedepunkt      = 86 °C<ref name=\\\"GESTIS\\\" />\\n| Dampfdruck      = 56 [[Hektopascal|hPa]] (20 °C)<ref name=\\\"GESTIS\\\" />\\n| pKs             = −1,37<ref>CCI ETH: [http://www.cci.ethz.ch/vorlesung/de/al1/img181.gif pK<sub>s</sub>-Tabelle]</ref>\\n| Löslichkeit     = mit Wasser in jedem Verhältnis mischbar, heftige Reaktion mit [[Ethanol]]<ref name=\\\"Merck\\\" >{{Merck|100450|Name=100%ige Salpetersäure|Datum=23. Januar 2018}}</ref>\\n| CLH             = {{CLH-ECHA|ID=100.028.832 |Name=Salpetersäure … % |Datum=24. Januar 2017}}\\n| Quelle GHS-Kz   = <ref name=\\\"GESTIS\\\">{{GESTIS|Name=Salpetersäure|ZVG=1370|CAS=7697-37-2|Datum=9. Januar 2019}}.</ref>\\n| GHS-Piktogramme = {{GHS-Piktogramme|03|06|05}}\\n| GHS-Signalwort  = Gefahr\\n| H               = {{H-Sätze|272|290|314|330}}\\n| EUH             = {{EUH-Sätze|071}}\\n| P               = {{P-Sätze|221|280|301+330+331}}\\n| Quelle P        = <ref name=\\\"GESTIS\\\" />\\n| MAK             = \\n* [[Arbeitsplatzgrenzwert|AGW]] der Technischen Regeln für Gefahrstoffe 900:<br />1 ml·m<sup>−3</sup> ([[parts per million|ppm]]), 2,6 mg·m<sup>−3</sup>.<br /><small>Der Arbeitsplatzgrenzwert ist nur als Kurzzeitwert festgelegt. Die betriebliche Überwachung soll durch messtechnische Mittelwertbildung über 15 Minuten erfolgen, z. B. durch eine 15 minütige Probenahme. Von der Europäischen Union wurde ein Luftgrenzwert festgelegt.<ref>[[Ausschuss für Gefahrstoffe|Ausschuss für Gefahrstoffe (AGS)]] der [[Bundesanstalt für Arbeitsschutz und Arbeitsmedizin|Bundesanstalt für Arbeitsschutz und Arbeitsmedizin (BAuA)]]: [http://www.baua.de/cln_137/de/Themen-von-A-Z/Gefahrstoffe/TRGS/TRGS-900.html Technische Regeln für Gefahrstoffe (TRGS) 900] ([http://www.baua.de/de/Themen-von-A-Z/Gefahrstoffe/TRGS/pdf/TRGS-900.pdf?__blob=publicationFile&v=16 PDF]), abgerufen am 10. Juni 2014.</ref><br />Spitzenbegrenzung: Überschreitungsfaktor 1.<br />Dauer 15 min, Mittelwert; 4-mal pro Schicht; Abstand 1 h<ref name=\\\"GESTIS\\\" /></small>\\n* Schweiz: 2 ml·m<sup>−3</sup> bzw. 5 mg·m<sup>−3</sup><ref>{{SUVA-MAK |Name=Salpetersäure |CAS-Nummer=7697-37-2 |Abruf=2015-11-02}}</ref>\\n| ToxDaten        = {{ToxDaten |Typ=LD<sub>Lo</sub> |Organismus=Mensch |Applikationsart=oral |Wert=430 mg·kg<sup>−1</sup> |Bezeichnung= |Quelle=<ref>Sicherheitsdatenblatt Bernd Kraft, Stand 29.05.2019. [http://sdbl.bkraft.de/10762de.pdf PDF], aufgerufen am: 20. Januar 2020.</ref> }}\\n}}\\n\\n'''Salpetersäure''' (HNO<sub>3</sub>) ist die bekannteste und stabilste [[Sauerstoffsäure]] des [[Stickstoff]]s. Der Name leitet sich vom [[Nitrate#Salpeter|Salpeter]] ab, aus dem sie durch Zugabe einer stärkeren Säure ([[Schwefelsäure]]) gewonnen werden kann.\\n\\nSalpetersäure liegt in wässriger Lösung weitgehend [[Dissoziation (Chemie)|dissoziiert]] vor. Als starke anorganische Säure zählt sie zu den [[Mineralsäure]]n. Ihre [[Salze]] und [[Ester]] heißen [[Nitrate]]. Die Salze werden auch mit dem [[Trivialname]]n „-salpeter“ gekennzeichnet, z. B.: [[Natriumnitrat|Chilesalpeter]], [[Kaliumnitrat|(Kali-)Salpeter]], [[Ammoniumnitrat|Ammonsalpeter]], [[Calciumnitrat|Kalksalpeter]] oder Mauersalpeter, [[Bariumnitrat|Barytsalpeter]] etc.\\n\\nDie reine Säure ist farblos und hat einen scharf stechenden Geruch. Sie wird unter anderem zur Herstellung von Düngemitteln, Farb- und Sprengstoffen verwendet.\\n\\n== Geschichte ==\\nIn der Schrift ''De inventione veritatis'' aus dem 12. Jahrhundert wird erwähnt, dass bereits im 9. Jahrhundert der arabische [[Alchemie|Alchimist]] [[Dschābir ibn Hayyān|Geber]] rohe Salpetersäure („Aqua dissolutiva“) durch trockenes Erhitzen von [[Nitrate#Salpeter|Salpeter]] ([[Latein|lat.]] ''sal petrae'' = Felsensalz; [[Kaliumnitrat|KNO<sub>3</sub>]]), Cyprischem [[Vitriol]] (CuSO<sub>4</sub>·5 H<sub>2</sub>O) und [[Alaun]] (KAl(SO<sub>4</sub>)<sub>2</sub>·12 H<sub>2</sub>O) gewonnen haben soll. Im 13. Jahrhundert soll [[Albertus Magnus]] die Salpetersäure benutzt haben, um [[Gold]] und [[Silber]] zu trennen (Scheidewasser, ''aqua fortis''<ref>Thomas Gleinser: ''Anna von Diesbachs Berner ‚Arzneibüchlein‘ in der Erlacher Fassung Daniel von Werdts (1658), Teil II: Glossar.'' (Medizinische Dissertation Würzburg), jetzt bei Königshausen & Neumann, Würzburg 1989 (= ''Würzburger medizinhistorische Forschungen'', 46), S. 38.</ref>). Jedoch wurden viele Schriften Albertus Magnus nur zugeschrieben, um ihnen höheres Gewicht zu verleihen, wahrscheinlich auch die über die Verwendung der Salpetersäure. Später wurde [[Nitrate#Salpeter|Salpeter]] mit Eisen[[vitriol]] (FeSO<sub>4</sub>·7 H<sub>2</sub>O) erhitzt, was höhere Ausbeuten bei niedrigerer Temperatur lieferte.\\n\\n[[Johann Rudolph Glauber|J. R. Glauber]] gewann Mitte des 17. Jahrhunderts reinen ''spiritus nitri'' durch Umsetzung und Destillation von Salpeter mit [[Schwefelsäure]], einem bis heute gebräuchlichen Laborverfahren zur Herstellung der Salpetersäure, die im [[Mittelalter]] auch ''aqua fortis'' oder ''aqua valens'' und im englischen Sprachraum ''strong water'' genannt wurde. Als Bestandteile der Salpetersäure erkannte [[Antoine Laurent de Lavoisier|A. L. Lavoisier]] Mitte des 18. Jahrhunderts die [[Chemisches Element|chemischen Elemente]] [[Stickstoff]] und [[Sauerstoff]]. Die genaue Zusammensetzung wurde von [[Henry Cavendish]] bestimmt, dem auch die Synthese aus dem Stickstoff der Luft durch [[elektrische Entladung]] gelang.\\n\\nEine rationelle Fabrikation begann erst Anfang des 19. Jahrhunderts, als billige Schwefelsäure und [[Chilesalpeter]] in ausreichenden Mengen verfügbar waren. Auch die [[Luftverbrennung]] in einem [[Lichtbogen|elektrischen Lichtbogen]] wurde zu einem großtechnischen Verfahren entwickelt ([[Kristian Birkeland|Birkeland]]–[[Sam Eyde|Eyde]]), das jedoch nur in Ländern mit billigem [[Elektrischer Strom|Strom]] konkurrenzfähig war. Die katalytische Oxidation von [[Ammoniak]] über [[Platin]] wurde von [[Frédéric Kuhlmann|C. F. Kuhlmann]] (1838) entdeckt. Bis zur Erfindung der [[Haber-Bosch-Verfahren|Ammoniaksynthese]] durch [[Fritz Haber|Haber]] und [[Carl Bosch|Bosch]] blieb jedoch Ammoniak zu teuer im Vergleich zu Chilesalpeter. Zu Beginn des 20. Jahrhunderts entwickelte [[Wilhelm Ostwald]] die Herstellung von Salpetersäure aus Ammoniak zur industriellen Reife. Die billige Ammoniak-Oxidation hat heute alle anderen großtechnischen Verfahren verdrängt.\\n\\n== Herstellung ==\\n[[Datei:Ostwaldverfahren Laboraufbau.jpeg|links|mini|Ein Laboraufbau des [[Ostwald-Verfahren]]s]]\\nSalpetersäure wird technisch seit 1908 nach dem [[Ostwaldverfahren]] hergestellt. Es handelt sich dabei um die katalytische [[Oxidation]] von [[Ammoniak]]. Das Ammoniak-Luft-Gemisch wird rasch (1/1000 s Berührungszeit) durch heiße [[Platin]]-[[Rhodium]]-Netze ([[Katalysator]]) geleitet. Bei 800 °C entsteht [[Stickstoffmonoxid]], das beim Abkühlen mit überschüssigem [[Sauerstoff]] zu [[Stickstoffdioxid]] und dann in Rieseltürmen mit Wasser zu etwa 60%iger Salpetersäure reagiert. Die 60%ige Salpetersäure kann durch [[Destillation]] bis 68 % konzentriert werden, was dem [[Azeotrop]] mit Siedepunktmaximum (122 °C) entspricht. Höhere Konzentrationen lassen sich durch Rektifikation (Entwässerung) mit [[Schwefelsäure]] (H<sub>2</sub>SO<sub>4</sub>) oder mit wässriger [[Magnesiumnitrat]]-Lösung (Mg(NO<sub>3</sub>)<sub>2</sub>) oder durch Behandlung von [[Distickstofftetroxid]] (N<sub>2</sub>O<sub>4</sub>) mit der [[stöchiometrisch]] nötigen Menge von Sauerstoff (bzw. Luft) und Wasser erreichen.\\n\\nIm Labormaßstab kann Salpetersäure durch Umsetzung konzentrierter [[Schwefelsäure]] mit [[Nitrat]]en dargestellt werden. Vor 1908 wurde Salpetersäure durch dieses Verfahren unter Verwendung von [[Natriumnitrat]] ([[Chilesalpeter]]) gewonnen.\\n\\n: <math>\\\\mathrm{ \\\\ NaNO_3 +  \\\\ H_2SO_4 \\\\longrightarrow  \\\\ NaHSO_4 +  \\\\ HNO_3}</math>\\n\\nOft auftretende Verunreinigungen der Säure mit Halogenen oder Halogenwasserstoffen lassen sich durch Zugabe von [[Silbernitrat]] und anschließende Destillation beseitigen. Wasserfreie Salpetersäure erhält man, von einer durch Destillation hochkonzentrierten Säure ausgehend, durch Durchleiten von [[Inertgas]] oder der Destillation über [[Phosphorpentoxid]] oder [[Rauchende Schwefelsäure|Oleum]].<ref>G. Brauer (Hrsg.), ''Handbook of Preparative Inorganic Chemistry'', 2nd ed., vol. 1, Academic Press 1963, S. 491–492.</ref>\\n\\n== Eigenschaften ==\\n[[Datei:Nitricacid.jpg|mini|links|100px|Salpetersäure]]\\n\\nSalpetersäure ist in reinem Zustand farblos. Konzentrierte Salpetersäure zersetzt sich jedoch leicht (besonders unter Lichteinwirkung) und hat aufgrund des in ihr gelösten [[Stickstoffdioxid]]s (NO<sub>2</sub>) oft einen gelblichen oder rötlichen Farbton.\\n\\n:<math>\\\\mathrm{4 \\\\ HNO_3 \\\\longrightarrow 4 \\\\ NO_2 + 2 \\\\ H_2O + O_2}</math>\\n\\nReine Salpetersäure, die freies Stickstoffdioxid enthält, wird rauchende Salpetersäure genannt. Sie enthält über 90 % HNO<sub>3</sub>, wirkt stark oxidierend und kann manche leicht brennbaren Stoffe entzünden; daher gilt Salpetersäure ab 70 % als [[Brandfördernde Stoffe|brandfördernd]]. Salpetersäure, die durch gelöstes Stickstoffdioxid gelb gefärbt ist, kann durch eine kleine Menge [[Harnstoff]] oder besser [[Harnstoffnitrat]] entfärbt werden.\\n\\nSalpetersäure ist sowohl ein starkes [[Oxidationsmittel]] als auch eine [[Starke Säuren|starke Säure]]. [[Nichtmetalle|Nichtmetallische]] [[Chemisches Element|Elemente]] wie [[Kohlenstoff]], [[Iod]], [[Phosphor]] und [[Schwefel]] werden durch [[Konzentration (Chemie)|konzentrierte]] Salpetersäure zu ihren [[Oxide]]n oder [[Oxosäuren]] unter Bildung von Stickstoffdioxid [[Oxidieren|oxidiert]], zum Beispiel\\n\\n:<math>\\\\mathrm{S + 6 \\\\ HNO_3 \\\\longrightarrow H_2SO_4 + 6 \\\\ NO_2 + 2 \\\\ H_2O}</math>\\n\\nDarüber hinaus werden viele Verbindungen durch Salpetersäure oxidiert. [[Salzsäure]] wird zu [[Chlor]] und [[Chlordioxid]] oxidiert.\\n\\n[[Nitrate]], die [[Salze]] der Salpetersäure, entstehen, wenn [[Metalle]] oder deren [[Oxide]], [[Hydroxide]] oder [[Carbonate]] mit Salpetersäure reagieren. Die meisten Nitrate sind wasserlöslich, und Salpetersäure wird hauptsächlich zur [[Herstellung]] löslicher Metallnitrate verwendet.\\n\\nSalpetersäure reagiert mit den meisten [[Metalle]]n unter Bildung wasserlöslicher Nitrate. Ausnahmen sind die [[Edelmetall]]e [[Gold]], [[Platin]] und [[Iridium]]. Auch [[Aluminium]], [[Titan (Element)|Titan]], [[Zirconium]], [[Hafnium]], [[Niob]], [[Tantal]] und [[Wolfram]] widerstehen der Salpetersäure durch [[Passivierung]]. Weiter ist [[Eisen]] infolge Passivierung resistent gegenüber kalter, [[Chrom]] auch gegenüber heißer Salpetersäure. Dabei bildet sich auf dem Metall eine fest haftende, undurchlässige Oxidschicht. Da man somit Gold und [[Silber]] trennen konnte, wurde sie früher ''Scheidewasser'' genannt. Mischungen von Salpetersäure mit [[Salzsäure]] ([[Königswasser]]) oder [[Selensäure]]<ref>E. Riedel, Christoph Janiak: Anorganische Chemie. 8. Auflage. de Gruyter, 2011, ISBN 3-11-022566-2, S. 458.</ref> reagieren auch mit Gold und Platin.\\n[[Datei:Xanthoprotein-Reaktion.jpg|mini|[[Xanthoprotein-Reaktion]]]]\\nSalpetersäure färbt [[Protein]]e, die [[Aromaten|aromatische]] [[Aminosäure]]n wie L-[[Phenylalanin]] oder L-[[Tyrosin]] enthalten, unter [[Nitrierung]] des [[Benzolring]]s gelb. Diese [[Xanthoprotein-Reaktion]] kann zum Nachweis von aromatischen Aminosäuren und Proteinen benutzt werden.\\n{| class=\\\"wikitable\\\"\\n|+Physikalische Eigenschaften von HNO<sub>3</sub>/H<sub>2</sub>O-Mischungen in Abhängigkeit von der Konzentration bei 20 °C und 1,013 bar<ref name=\\\"Ullmann\\\">M. Thiemann, E. Scheibler, K.W. Wiegand: ''Nitric Acid, Nitrous Acid, and Nitrogen Oxides'' in [[Ullmanns Enzyklopädie der Technischen Chemie]], Wiley-VCH Verlag GmbH & Co. KGaA, Weinheim 2005, {{DOI|10.1002/14356007.a17_293}}.</ref>\\n! Gew % HNO<sub>3</sub>\\n! 0\\n! 10\\n! 20\\n! 30\\n! 40\\n! 50\\n! 60\\n! 70\\n! 80\\n! 90\\n! 100\\n|-\\n! [[Dichte]]<br />(g/cm<sup>3</sup>)\\n| align=\\\"center\\\"|1,00\\n| align=\\\"center\\\"|1,05\\n| align=\\\"center\\\"|1,12\\n| align=\\\"center\\\"|1,18\\n| align=\\\"center\\\"|1,25\\n| align=\\\"center\\\"|1,31\\n| align=\\\"center\\\"|1,37\\n| align=\\\"center\\\"|1,42\\n| align=\\\"center\\\"|1,46\\n| align=\\\"center\\\"|1,48\\n| align=\\\"center\\\"|1,513\\n|-\\n! [[Viskosität]]<br />(mPa·s)\\n| align=\\\"center\\\"|1,00\\n| align=\\\"center\\\"|1,04\\n| align=\\\"center\\\"|1,14\\n| align=\\\"center\\\"|1,32\\n| align=\\\"center\\\"|1,55\\n| align=\\\"center\\\"|1,82\\n| align=\\\"center\\\"|2,02\\n| align=\\\"center\\\"|2,02\\n| align=\\\"center\\\"|1,84\\n| align=\\\"center\\\"|1,47\\n| align=\\\"center\\\"|0,88\\n|-\\n! [[Schmelzpunkt|Smp]] (°C)\\n| align=\\\"center\\\"|0\\n| align=\\\"center\\\"|−7\\n| align=\\\"center\\\"|−17\\n| align=\\\"center\\\"|−36\\n| align=\\\"center\\\"|−30\\n| align=\\\"center\\\"|−20\\n| align=\\\"center\\\"|−22\\n| align=\\\"center\\\"|−41\\n| align=\\\"center\\\"|−39\\n| align=\\\"center\\\"|−60\\n| align=\\\"center\\\"|−42\\n|-\\n! [[Siedepunkt|Sdp]] (°C)\\n| align=\\\"center\\\"|100,0\\n| align=\\\"center\\\"|101,2\\n| align=\\\"center\\\"|103,4\\n| align=\\\"center\\\"|107,0\\n| align=\\\"center\\\"|112,0\\n| align=\\\"center\\\"|116,4\\n| align=\\\"center\\\"|120,4\\n| align=\\\"center\\\"|121,6\\n| align=\\\"center\\\"|116,6\\n| align=\\\"center\\\"|102,0\\n| align=\\\"center\\\"|86,0\\n|-\\n! [[Partialdruck|p]](HNO<sub>3</sub>) (mbar)\\n| align=\\\"center\\\"|0,0\\n| align=\\\"center\\\"|0,0\\n| align=\\\"center\\\"|0,0\\n| align=\\\"center\\\"|0,0\\n| align=\\\"center\\\"|0,0\\n| align=\\\"center\\\"|0,3\\n| align=\\\"center\\\"|1,2\\n| align=\\\"center\\\"|3,9\\n| align=\\\"center\\\"|14,0\\n| align=\\\"center\\\"|36,0\\n| align=\\\"center\\\"|60,0\\n|-\\n! [[Partialdruck|p]](H<sub>2</sub>O) (mbar)\\n| align=\\\"center\\\"|23,3\\n| align=\\\"center\\\"|22,6\\n| align=\\\"center\\\"|20,2\\n| align=\\\"center\\\"|17,6\\n| align=\\\"center\\\"|14,4\\n| align=\\\"center\\\"|10,5\\n| align=\\\"center\\\"|6,5\\n| align=\\\"center\\\"|3,5\\n| align=\\\"center\\\"|1,2\\n| align=\\\"center\\\"|0,3\\n| align=\\\"center\\\"|0,0\\n|-\\n! Konzentration|HNO<sub>3</sub> (mol/l)\\n| align=\\\"center\\\"|\\n| align=\\\"center\\\"|1,7\\n| align=\\\"center\\\"|3,6\\n| align=\\\"center\\\"|5,6\\n| align=\\\"center\\\"|7,9\\n| align=\\\"center\\\"|10,4\\n| align=\\\"center\\\"|13,0\\n| align=\\\"center\\\"|15,8\\n| align=\\\"center\\\"|18,5\\n| align=\\\"center\\\"|21\\n| align=\\\"center\\\"|24,01\\n|}\\n\\n== Verwendung ==\\nSalpetersäure ist einer der wichtigsten Grundstoffe der chemischen Industrie. Sie dient:\\n* zur Herstellung von [[Nitrat]]en und [[Düngemittel]]n,\\n* als ''Scheidewasser'' zur Trennung ([[Quartation]]) von Gold und Silber (Silber reagiert unter Bildung von löslichem [[Silbernitrat]]),\\n* in Mischungen mit [[Salzsäure]] als [[Königswasser]] zum Lösen von Gold, sowie zum [[Vergolden]] und zum Nachweis von Gold,\\n* zum [[Beizen]] und [[Beizen#Beizen anderer Metalle|Brennen]] von Metallen (grafische und galvanische Technik),\\n* zur [[Nitrierung]] von organischen Stoffen bei der Herstellung von [[Farbstoff]]en, [[Heilmittel]]n, [[Desinfektionsmittel]]n und [[Explosivstoff]]en wie [[Nitroglycerin]] oder [[Schießbaumwolle]],\\n* zur Herstellung von [[Celluloid]], [[Nitrozelluloselacke|Nitrolacken]] und [[Zaponlack]]en,\\n* zum Verändern von Fetten (Wasserlöslichkeit) zum Zwecke der Reinigung,\\n* zum Polieren von Metallen,\\n* in [[Raketentreibstoff]]en als Oxidationsmittel ([[WFNA]] und [[RFNA]]).\\n\\n== Nachweis ==\\nSalpetersäure kann im Labor wie die [[Nitrat]]e durch die [[Ringprobe]] und durch [[Lunges Reagenz]] nachgewiesen werden.\\n\\n== Sicherheitshinweise ==\\nSalpetersäure wirkt auf Haut, Atemwege und Schleimhäute ätzend. Das Einatmen der Dämpfe kann zu einem toxischen [[Lungenödem]] führen. Diese Gefahr besteht vor allem beim Erhitzen oder bei der konzentrierten Säure. In hoher Konzentration ist sie ein starkes Oxidationsmittel und wirkt brandfördernd. Salpetersäure reagiert mit den meisten Metallen unter Bildung von toxischem [[Stickstoffdioxid]]. Beim Arbeiten mit Salpetersäure sind eine Schutzbrille oder ein Gesichtsschild, geeignete Schutzhandschuhe und ein geschlossener Arbeitskittel zu tragen. Besteht die Gefahr, dass in einem Raum Salpetersäure-Dämpfe oder Stickoxide frei werden, muss ein Atemschutz-Gerät getragen werden. Salpetersäure eignet sich aus diesem Grund nicht für Reinigungs-Zwecke im Haushalt. Das Arbeiten im Labor erfolgt stets in einem Abzug. Für Flaschen mit konzentrierter Salpetersäure wird ein Teflonverschluss empfohlen.<ref>Thomas Seilnacht: ''Naturwissenschaften unterrichten'', Eintrag [http://www.seilnacht.com/Chemie/ch_hno3.htm Salpetersäure] und Thomas Seilnacht: ''DVD-ROM Chemie'', Seilnacht Verlag & Atelier, Bern 2017.</ref>\\n\\n== Siehe auch ==\\n* [[Salpetrige Säure]] (HNO<sub>2</sub>)\\n\\n== Weblinks ==\\n{{Commonscat|Nitric acid|Salpetersäure}}\\n{{Wiktionary}}\\n* Schulrelevante Infos zur [http://www.seilnacht.com/Chemie/ch_hno3.htm Salpetersäure] auf www.seilnacht.com, ''Naturwissenschaften unterrichten''.\\n\\n== Einzelnachweise ==\\n<references />\\n\\n{{Normdaten|TYP=s|GND=4178973-8|LCCN=sh/85/092048|NDL=00572280}}\\n\\n{{SORTIERUNG:Salpetersaure}}\\n[[Kategorie:Anorganische Säure]]\\n[[Kategorie:Stickstoffverbindung]]\\n[[Kategorie:Sauerstoffverbindung]]\"";
  
  // result will be a tuple containing the start and end indices for the first match in the string
  let result = regex.captures(string);
  
  let (start, end) = match result {
    Some((s, e)) => (s, e),
    None => {
        // ...
    }
  };
  
  
  println!("{}", &string[start, end]);
}