const regex = /moduleName: ["']?github\.com\/(?<depName>[\w\-]+\/[\w\-\.]+)["']?,?\s+version:\s+["']?(?<currentValue>[_\-\.\w]+)["']?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('moduleName: ["\']?github\\.com\\\/(?<depName>[\\w\\-]+\\\/[\\w\\-\\.]+)["\']?,?\\s+version:\\s+["\']?(?<currentValue>[_\\-\\.\\w]+)["\']?', 'gm')
const str = ` plugins:
plugin-name: { moduleName: github.com/maxlerebourg/crowdsec-bouncer-traefik-plugin, version: v1.3.0 }
plugins:
plugin-name:
moduleName: "github.com/maxlerebourg/crowdsec-bouncer-traefik-plugin"
version: 'v1.3.0'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}