$re = '/(?<=1)(0*)(?=1)/';
$str = '1000010001';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);