package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d_([a-zA-Z_]+)_[0-9]+_`)
var str = ` abc_account2621_activity_20161116_20161117_030627_311999667.csv
abc_account2621_click_2016111606_20161116_221031_311735299.csv
abc_account2621_impression_2016111605_20161116_221808_311685411.csv
abc_account2621_rich_media_2016111606_20161116_192542_311735300.csv
abc_account2621_match_table_actwd342ivity_cats_20161116_20161117_0311_31.csv.gz
abc_account2621_match_table_activity_tdwypes_20161116_20161117_0342_31.csv.gz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}