$re = '/http:\/\/(?:[0-9]+?\.){3}[0-9]+?\:[0-9]+?\/tji\.html/';
$str = 'http://210.124.84.15/tji.html
http://210.124.84.15:8087/tji.html
http://210.84.15:8087/tji.html
http://210.124.84.15:8087/tji\\.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);