re = /http:\/\/(?:[0-9]+?\.){3}[0-9]+?\:[0-9]+?\/tji\.html/
str = 'http://210.124.84.15/tji.html
http://210.124.84.15:8087/tji.html
http://210.84.15:8087/tji.html
http://210.124.84.15:8087/tji\\.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end