use strict;
my $str = 'iduser + CaSe WhEn ("end") = 0 THEN \'CASE WHEN\' ELSE \' END \' END + sum(iduser ) + CASE WHEN LANGUAGE = 3 THEN 4 ELSE 5 END';
my $regex = qr/(?(DEFINE)
(?<expr> \w+ | '[\w\s]*' | "[\s\w]*" | \(\s*(?&expr)\s*\) )
(?<clause> (?&expr)\s*=\s*(?&expr) )
(?<case> case \s+ when \s+ (?&clause) \s+ then \s+ (?&expr) \s+ else \s+ (?&expr) \s+ end)
)
(?i)(\s* (?&case) \s*)+/mxip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}