// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mxi)(?(DEFINE)
(?<expr> \w+ | '[\w\s]*' | "[\s\w]*" | \(\s*(?&expr)\s*\) )
(?<clause> (?&expr)\s*=\s*(?&expr) )
(?<case> case \s+ when \s+ (?&clause) \s+ then \s+ (?&expr) \s+ else \s+ (?&expr) \s+ end)
)
(?i)(\s* (?&case) \s*)+"#).unwrap();
let string = "iduser + CaSe WhEn (\"end\") = 0 THEN 'CASE WHEN' ELSE ' END ' END + sum(iduser ) + CASE WHEN LANGUAGE = 3 THEN 4 ELSE 5 END";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}