const regex = /\.\s+(\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.\\s+(\\d+)', 'g')
const str = `1. foo. 2. bar. 3. baz.`;
const subst = `.\n$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);