re = /(the|my) .*?(?P<bar>\w+) Foo/m
str = 'FooFooFoo the FooFoo the Bar Foo
FooFooFoo the FooFoo my Bar Foo
FooFooFoo my FooFoo my Bar Foo
FooFooFoo my FooFoo the Bar Foo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end